Platform lag/low fps

  • Is this a server problem or just my weak PC?


    Dual Core E5200 2.50Ghz
    3Gb of Ram
    512Mb of Vram, Ati Readon 4550
    Windows 10 Home Edition


    1 mb/s download speed & around 150 kb/s upload speed.


    I do remember that it was laggy on TW server too but I always thought that it's because of the distance of the server...
    Anyone else experiencing this? Even with stronger PC's?

  • And here I thought that my PC was getting really old.... (technically it is xD)
    There's this cheap i5 PC that I considered buying even tho I am not into games, just for DBO but if that's the case then never mind. (I am a performance sucker)

    the fact im using windows 8 and i lag on an old game >_>"""

    I hardly doubt that the OS matters here. Maybe a little bit.

  • They are all up to date. I have ok FPS & speed anywhere else except on platform when there are a lot of people throwing magic. Its gets a bit slower. Thanks for your opinions & advice on this matter tho~

  • Sorry for reviving this one but I am curious. How much fps do you guys get while playing DBO?


    I just checked and I get around 15-25 in Majin City, near it killing mobs and around 10-15 on platform.... That's pretty low.
    I tried changing the settings but I did not notice any major difference... At least not in the FPS.


    I used Fraps to check it.
    An interesting thing that happened is: I changed from 1600x900 resolution to 1024x786 and I noticed performance improvements. Then I changed back to 1600x900 and the performance stayed. Pretty weird, resolution shouldn't really affect the performance of a game a lot...

  • Sorry for reviving this one but I am curious. How much fps do you guys get while playing DBO?


    I just checked and I get around 15-25 in Majin City, near it killing mobs and around 10-15 on platform.... That's pretty low.
    I tried changing the settings but I did not notice any major difference... At least not in the FPS.


    I used Fraps to check it.
    An interesting thing that happened is: I changed from 1600x900 resolution to 1024x786 and I noticed performance improvements. Then I changed back to 1600x900 and the performance stayed. Pretty weird, resolution shouldn't really affect the performance of a game a lot...

    tatami 2-15 fps
    In other zone 15-25 fps

  • Windows 10 has nothing to do for it. the launcher itself is designed around using windows 8 and windows 10. Most problems come from users who are on windows 7 and below.


    I'm on windows 10 and have had little to no lag problems only noticeable visuals are when i fly over to korin village or something when there's loads of players at the platform.


    It may be your internet connection speeds or ping. I may also be problems with your hardware not being able to keep up.


    Think about it this way. if your game runs relatively fine when questing and in other areas that is because there's usually not very many people about so your computer hasn't got as much work to do. But when you go to the platform the screen and server has to deal with everything that is happening around you at the same time so it may lag as it struggles to show and register it at once.

    Gtx 650, 8gbram,i7 , win10, 25fps

    shit of W10